Lab 3 Relationships in ER Diagram and Relationships in MS Access

Summary
- Introduction to Relationships
- Why Define Relationships?
- Relationships in ER Diagram vs. Relationships in MS Access
- Creating Relationships Between Tables
  - One-to-Many Relationship (1:N)
  - Many-to-Many Relationship (M:N)
- Creating a Field/Column that looks up or lists values in tables
  - Creating a field that looks up data from another table
  - Creating a field that lists values from another table

1. Introduction: What is a Relationship?
Definition in class: An association between 2 (or more) separate entities.
Definition in MS Access: An association between 2 common fields (column) in two tables.

There are three types of relationships:
- One-to-One (1:1)
- One-to-Many (1:N)
- Many-to-Many (M:N).

2. Why Define Relationships?
After you've set up different tables for each subject in your Microsoft Access Database, you need a way of telling Microsoft Access how to bring that information back together again. The first step in this process is to define relationships between your tables. After you've done that, you can create queries, forms, and reports to display information from several tables at once. For example, the form in Fig. 1 includes information from five tables:

Fig. 1: A Form Using Information from Five Tables
How do relationships work?
In the previous example in Fig. 1, the fields in five tables must be coordinated so that they show information about the same order. This coordination is accomplished with **relationships** between tables. A relationship works by matching data in key fields — usually a field with the same name in both tables. In most cases, these matching fields are the **primary key** from one table, which provides a unique identifier for each record, and a **foreign key** in the other table. For example, employees can be associated with orders they’re responsible for by creating a relationship between the “Employees” table and the “Orders” table using the **EmployeeID** fields (which we will show later).

3. Relationships in ER Diagram vs MS Access

3.1 Relationships in ER Diagram
Let’s take a look at the relationship between the “EMPLOYEE” entity and the “ORDER” entity in Fig. 2. ‘Takes’ is a one-to-many relationship. The ‘Takes’ relationship can be converted into an MS Access relationship as shown in Fig 3.

3.2 Relationships in MS Access
Please refer to Fig. 3, which corresponds to the relationship in ER diagram shown in Fig. 2.

4. Creating Relationships Between Tables
Again, we will be using Northwind Sample Database. Open it as before from Help menu.

4.1 One-to-One relationship
In a one-to-one relationship, each record in Table A can have only one matching record in Table B and each record in Table B can have only one matching record in Table A. This type of relationship is NOT common, because most information related in this way would be in one table. You might use a one-to-one relationship to divide a table with too many fields, to isolate part of a table for security reasons, or to store information that applies only to a subset of the main table. For example, you might want to create a table to track employees participating in a fundraising soccer game.

### 4.2 One-to-many Relationship

A one-to-many relationship is the most common type of relationship. In a one-to-many relationship, a record in Table A can have many matching records in Table B, but a record in Table B has only one matching record in Table A. Refer to Fig. 4 for Supplier table as A, and Products table as B.

**Defining a One-to-many Relationships between Tables**

1. Close any tables you have open. You can't create or modify relationships between any open tables.
2. If you haven't already done so, switch to the Database Window. You can press F11 to switch to the Database window from any other window.
3. Click on menu Tools → Relationships (Note: when you do this, the toolbar in the window will look different, refer to Fig.3) If the relationships are already defined for the database, a relationship view of the current database will show up and look like Fig. 5.
4. If your database does not have any relationships defined, the Show Table dialog box will automatically be displayed (Fig. 6). Add the tables that you want to relate. When the Show Table dialog box isn't displayed, in the Relationships View (which you originally accessed via the menu Tool → Relationships), click on menu relationships →Show Table or right-click and select Show Table.
Ken Goldberg Database Lab Notes

**Fig. 4 One-to-Many Relationship**

<table>
<thead>
<tr>
<th>Supplier ID</th>
<th>Company Name</th>
<th>Contact Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Exotic Liquids</td>
<td>Charlotte Cooper</td>
</tr>
<tr>
<td>2</td>
<td>New Orleans Cajun Delights</td>
<td>Shelly Burke</td>
</tr>
<tr>
<td>3</td>
<td>Grandma Kelly’s Homestead</td>
<td>Regina Murphy</td>
</tr>
<tr>
<td>4</td>
<td>Tokyo Traders</td>
<td>Yoshi Nagase</td>
</tr>
</tbody>
</table>

... can supply more than one product

<table>
<thead>
<tr>
<th>Product ID</th>
<th>Product Name</th>
<th>Units in Stock</th>
<th>Supplier ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Chei</td>
<td>99</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Chang</td>
<td>17</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Aniseed Syrup</td>
<td>13</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>Chef Anton's Cajun Seasoning</td>
<td>63</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>Chef Anton's Gumbo Mix</td>
<td>0</td>
<td>2</td>
</tr>
</tbody>
</table>

But each product has only one supplier.

**Fig. 5 Relationships View of a Northwind Database**

**Fig. 6 Sample “Show Table” Dialog Box**
5. Once in the relationship view you have all the tables you want to relate, then you need to define the relationship between any two tables by dragging the field that you want to relate from one table to the related field in the other table (refer to Fig. 7). To drag multiple fields, press the CTRL key and click each field before dragging them. In most cases, you drag the primary key field (which is displayed in bold text) from one table to a similar field (often with the same name) called the foreign key in the other table. The related fields are NOT required to have the same names (Note it is good practice to do so since it reminds you where the relationship comes from), but they MUST have the same domain (or data type) and contain the same kind of information. In addition, when the matching fields are Number fields, they must have the same FieldSize property setting. The two exceptions to matching data types:
   - you can match an AutoNumber field with a Number field whose FieldSize property is set to Long Integer
   - you can also match an AutoNumber field with a Number field if both fields have their FieldSize property set to ReplicationID.

6. Once you have created the relationships, the Edit Relationships dialog box is displayed as shown in Fig. 8. Check the field names displayed in the two columns to ensure they are correct. You can change them if necessary. Set the relationship options if necessary. For information about a specific item in the Relationships dialog box, click on the question mark button (the cursor would now have a floating question mark next to it) and then click on the item.

7. Click the Create button to create the relationship.

8. Repeat steps 5 through 8 for each pair of tables you want to relate.

---

1. Primary key: one or more fields whose value or values uniquely identify each record in a table. In a relationship, a primary key is used to refer to specific records in one table from another table.

2. Foreign key: one or more table fields that refer to the primary key field or fields in another table. A foreign key indicates how the tables are related. The data in the foreign key and primary key fields must match. For example, the Products table in the Northwind sample database contains the foreign key SupplierID, which refers to the SupplierID primary key of the Suppliers table. Using this relationship, the Products table displays a supplier name from the Suppliers table for each product.

3. Data type: the attribute of a variable or field that determines what kind of data it can hold. For example, the Text and Memo field data types allow the field to store either text or numbers, but the Number data type will allow only numbers to be stored in the field. Number data type fields store numerical data that will be used in mathematical calculations. Use the Currency data type to display or calculate currency values. Supported data types include field data types, Visual Basic data types, and query parameter data types.
Notes

- You can edit the relationship between the two tables later on, by just double-clicking on the Relationship Line (shown in both Fig. 5 and Fig. 7) connecting the two tables in Relationships View. Please keep in mind that when you delete a table from the Relationship Views, it only changes the layout you see but not the relationship itself.
- When you close the Relationships window, Microsoft Access asks if you want to save the layout. Whether you save the layout or not, the relationships you create are saved in the database.
- If you need to view all the relationships defined in the database, click Show All Relationships on the toolbar. To view only the relationships defined for a particular table, click the table, and then click Show Direct Relationships on the toolbar.
- If you need to make a change to the design of a table, you can right-click the table you want to change, and then click Design Table.
- You can create relationships using queries as well as tables. However, referential integrity isn't enforced with queries.
- To create a relationship between a table and itself, add that table twice. This is useful in situations where you need to perform a lookup within the same table. For example, in the Employees table in the Northwind sample database, a relationship has been defined between the EmployeeID and ReportsTo fields, so that the ReportsTo field can display employee data from a matching EmployeeID.

![Edit Relationships Dialog Box](image)

**Fig. 8: “Edit Relationships” Dialog Box**

### 4.3 Many-to-many Relationship

In a many-to-many relationship, a record in Table A can have many matching records in Table B, and a record in Table B can have many matching records in Table A. This type of relationship is only possible by defining a third table, called a junction table, whose primary key consists of two fields: the primary keys from both Tables A and B. A many-to-many relationship is really two one-to-many relationships with a third table. For example, the Orders table and the Products

---

4 Referential integrity: Rules that you follow to preserve the defined relationships between tables when you enter or delete records. If you enforce referential integrity, Microsoft Access prevents you from adding records to a related table when there is no associated record in the primary table, changing values in the primary table that would result in orphan records in a related table, and deleting records from the primary table when there are matching related records in a related table.
table in Fig. 9 have a **many-to-many** relationship that’s defined by creating two **one-to-many** relationships with the **Order Details** table.

![Fig. 9: Many-to-many Relationship](image)

**Defining a Many-to-many Relationship between Tables**

**Fig. 10** shows a relationship view for Northwind database containing a many-to-many relationship between Products and Orders. Please refer to it while you understand the following steps.

1. Create the two tables that will have a **many-to-many** relationship.
2. Create a third table, called a **junction table**, and add fields with the same definitions as the primary key fields from each of the other two tables to this table. In the junction table, the **primary key** fields function as **foreign keys**. You can add other fields to the junction table, just as you can to any other table.
3. In the **junction table**, set the **primary key** to include the **primary key** fields from the other two tables. For example, in an **Order Details** junction table, the primary key would be made up of the **OrderID** and **ProductID** fields. (Note: You can set multiple fields as the **primary key** by highlighting multiple rows (which correspond to fields) which you want to be part of your **primary key** in **Design View**, and then click on **Edit → Primary Key**. Alternatively you can also use the **primary key** button in the tool bar)
4. Define a **one-to-many** relationship between each of the two **primary tables** and the **junction table**.
5. To add data to the tables, create a **form** that works with more than one table.

**Note:**

In the Northwind sample database, a **many-to-many** relationship exists between the **Orders** and **Products** tables. One order in the **Orders** table can include multiple products from the **Products** table. In addition, a single product can appear in many orders. In the sample database, the **Order Details** table is a **junction table** between the **Orders table** and the **Products table**.

---

5 Form: a Microsoft Access database object on which you place controls for taking actions or for entering, displaying, and entering data in fields.
5. Creating a field that looks up or lists values in tables

5.1 Lookup Wizard
When you set up the fields for the table, you can create a field that displays either of two kinds of lists to make data entry simpler by means of Lookup Wizard:

- **Lookup list** that displays values looked up from an existing table or query
- **Value list** that displays a fixed set of values that you enter when you create the field

We will introduce how to use the lookup wizard in design view to generate lookup list and value in the following two sections.

5.2 Creating a field that looks up data from another table in Design view

**Lookup List**
The most common Lookup list displays values looked up from a related table. For example, the SupplierID field in the Products table of the Northwind sample database displays the Lookup list as shown in Fig. 11.
You can add a new Lookup field in either design view or datasheet view of tables. However, if the field you want to use as the foreign key for a Lookup field already exists, you must open that field's table in Design view to define the Lookup field. For example, assume you already have a Suppliers table filled with data, now you want to create a Products table containing a SupplierID field whose contents should come form the Suppliers table. You can make the data entry simpler for this by changing it to a Lookup field, so that a drop-down list containing all supplier IDs from Suppliers table will be available when you start to enter data into Products table. In order to do this, you must open the Products table in Design view to change SupplierID to a Lookup field. Here are the steps to follow:

1. Open the table in Design view.
2. Do one of the following:
   - If the SupplierID field is not defined yet, click in the row below where you want to add the field, and then click Insert → Rows on the toolbar, or to add a new field at the end of the table, click in the first blank row. Type SupplierID in the Field Name column, following Microsoft Access object-naming rules.
   - If the SupplierID is already defined, click the corresponding row.
3. In the 'Data Type' column, click the down arrow and select 'Lookup Wizard' from the list.
4. Click the option that indicates you want the Lookup field to look up the values in a table or query.
5. Click Next and follow the directions in the remaining Lookup Wizard dialog boxes.

When you click the Finish button, Microsoft Access creates the Lookup field and sets certain field properties based on the choices you made in the wizard. For information on the properties that the Lookup Wizard sets, go back to the field that was set by the Lookup Wizard, and click on the Lookup tab in the Field Properties window (Fig. 12).

**Fig. 12: Properties Listed in the Lookup Tab in the Field Properties Window**

---

6 Lookup list field and form: once you’ve created a Lookup list field, if you add the field to a form, Microsoft Access copies its definition into the form. You won’t have to create the combo or list box and its Lookup or value list definition for the form. However, if you change the definition of a Lookup or value list field in the table after adding it to a form, those changes will NOT be reflected in that form. To correct this, delete the field from the form and then add it again.
Note:
- It is also possible to add a Lookup field to a table that displays values from the same table that contains the Lookup field. For example, in the Employees table of the Northwind sample database the ReportsTo field is a Lookup field that displays data from the FirstName and LastName fields by looking up the corresponding EmployeeID in the same table.

Now let's go back to Fig. 11. It is created by looking up the SupplierID values in the Suppliers table and by displaying the corresponding Supplier names. Picking a value from a Lookup list sets the foreign key value in the current record (SupplierID in the Products table) to the primary key value of the corresponding record in the original table (SupplierID in the Suppliers table). This creates an association to the related table to display (but NOT store) the Supplier names in the record. The foreign key (SupplierID) is stored but is not displayed. For this reason, any updates made to the data in the Suppliers table will be reflected in both the list and records in the Products table. You must define a Lookup field in the table that will contain the foreign key and display the Lookup list. In this example, the Lookup list field would be defined in the Products table.

5.3 Create a value list field in Design view

Value List
A Value list looks the same as a Lookup list, but consists of a fixed set of values you type in when you create it. A value list should only be used for values that will not change very often and don't need to be stored in a table. For example, a list for a Salutation field containing Mr., Mrs., or Ms. would be a good candidate for a value list. Choosing a value from a value list will store that value in the record. It doesn't create an association to a related table. For this reason, if you change any of the original values in the value list later, they will not be reflected in records added before this change was made.

1. Open the table in Design view.
2. To insert the field within the table, click in the row below where you want to add the field, and then click Insert → Rows on the toolbar.
3. To add the field to the end of the table, click in the first blank row.
4. In the Field Name column, type the name for the field, following Microsoft Access object-naming rules.
5. In the Data Type column, click the arrow and select Lookup Wizard.
6. In the first Lookup Wizard dialog box, click the option that indicates you will type in the values that you want.
7. Click Next and follow the directions in the remaining Lookup Wizard dialog boxes.

Note:
- When you use the Lookup Wizard to create a fixed value list, Microsoft Access sets certain field properties based on the choices you made in the wizard.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
WELL DONE !! YOU HAVE JUST LEARNED HOW TO CREATE DIFFERENT RELATIONSHIPS BETWEEN TABLES, AND ALSO TO ENHANCE YOUR TABLES USING LOOKUP & VALUE LISTS
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

7 Value list field and form: once you've created the field, if you add it to a form, Microsoft Access copies its definition into the form. You won't have to create the value list definition for the form. However, if you change the definition of the value list field in the table after adding it to a form, those changes will not be reflected in that form. To correct this, delete the field from the form and then add it again.
Quiz 3

(Due at the start of next class)

Using your **car.mdb** (which includes the following tables):
- Customer: CustomerID, CustomerName, City, Discount
- VehicleInstance: VehicleID, VehicleName, Price, Discount
- Dealership: DealerID, DealerName, City, Commission

1. Enter as many tuples/rows of data for the 'VehicleInstance' table as you like (>10 instances) and 10 tuples/rows of data for the 'Customer', and 'Dealership' tables.

2. Create relationships that connect the different entities according to the following assumptions:
   a. A Dealership can have multiple instances of the same Vehicle
   b. A Customer or a Dealership must own a particular instance of a Vehicle
   c. A Customer can own multiple Vehicles and can also be a client of multiple Dealerships

Further instructions:
For the quiz, please provide:
- screenshots for ALL records in each table, and try to fit 3 tables in a page
- screenshot for ALL relationships in the Relationship window

To do a **screenshot capture**, open the window which you want to capture, maximize it (or size it appropriately) and then do **Alt+Print Screen**. Then use the **Paste** command in your word processing software to import the image into your document.